Eğer bir F klavye kullanıcısıysanız ve Ubuntu'dan başka limanlara geçmek istediyseniz farketmiş olmalısınız ki her dağıtım TRF düzenine yeterli desteği vermiyor. Az kullanılan bir klavye düzeni olduğu için ne İngilizce ne Türkçe kaynak bulamadım. openSUSE ise bunların arasında hiç destek vermeyenlerden. Kurulum sırasında F klavye kullanmayı unutun önce. Endişelenmeyin, kurulumda yazacak çok şey yok. Şimdi bu rehberde kurulumu tamamladığınızı ve masaüstüne geldiğinizi varsayacağım.

DİKKAT !
Bu rehberi openSUSE forumunda yazmış olsak da bu sorunlardan herhangi birisini kendi dağıtımınızda yaşıyorsanız rehberimizden faydalanabilirsiniz.

Şimdi sorunları ve bu sorunların çözümlerine geçelim;

1-Sistem içinde Q klavye aktif.
Bunun çözümü çok basit. Sadece başlat menüsünden klavye yazın ve resimdeki gibi 2. menüden F klavyeyi seçin.

Resim

2- Giriş yapma ekranında Q klavye aktif ve F'e geçemiyorum
Bu senaryoda X sunucusunun ayarlarından kaynaklı bir sorun var. "/etc/X11/xorg.conf.d/00-keyboard.conf" dosyanızı düzenlemelisiniz.

Kod: Tümünü seç

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "tr"
        Option "XkbModel" "pc105"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Normalde openSUSE kullanıcısıysanız bu dosya buna benzeyecek. Yapmak istediğiniz layout'a bir variant atamak. Yapmanız gereken tek şey tek bir satırı kopyala yapıştır yapmak.

Kod: Tümünü seç

Option "XkbVariant" "f"
Dosya işlem sonrasında şuna benzemeli.

Kod: Tümünü seç

  GNU nano 4.7             /etc/X11/xorg.conf.d/00-keyboard.conf                        
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "tr"
        Option "XkbModel" "pc104"
        Option "XkbVariant" "f"
        Option "XkbOptions" "grp:alt_shift_toggle"
EndSection
Yeniden başlatın ve sorununuz çözülmüş olmalı.

3- TTY ekranında (siyah ekranda) Q klavye aktif
Öncelikle burada Q klavye ile giriş yapmaktan başka çare yok. Kullanıcı ismini ve şifrenizle giriş yapın. Giriş yaptıktan sonra

Kod: Tümünü seç

sudo loadkeys trf
komutu ile F klavye düzenine geçin. F'e şimdilik geçtiniz ama sorun henüz kalıcı olarak düzelmedi. Çünkü bu her yeniden başlattığınızda tekrarlanacak böyle bırakırsanız. Yapmanız gereken şey "/etc/vconsole.conf" dosyasını düzenlemek.

Kod: Tümünü seç

KEYMAP=tr-f
FONT=eurlatgr.psfu
FONT_MAP=none
FONT_UNIMAP=
Yapmanız gereken tek şey KEYMAP'i tr-f'e eşitlemek. Bu TTY ekranına her geçtiğinizde TRF düzenini kullanmasını sağlayacak.

Bunun dışında Wine'de F klavye ile ilgili sıkıntılar yaşamanız olası. Steam'de CS:GO gibi Valve oyunları da dahil bir çok oyunun F klavye desteği bulunmakta. Malesef bizim klavyemiz Q klavye kadar yaygın kullanılmadığı için desteği daha da az. Umarım sorunlarınza dilim döndüğünce yardım edebilmişimdir. Eğer sorununuz hala devam ediyorsa yada başka bir sorununuz varsa yorumlar kısmında belirtin. İyi günler.