Çözüldü / Codec not supported uyarısının çözümü nedir?

OpenSuSE için basit konular hakkında teknik destek alanı

Moderatör: tyko

Codec not supported:
VLC could not decode the format "mp4a" (MPEG AAC Audio)

Uyarısının çözümü nedir?
İyi yıllar

Önce packman deposunu aktifleştirin.

viewtopic.php?f=5&t=42

Sonra depodan codecleri yönetici olarak kurunuz (başına sudo ekleyin ya da önceden su yazarak root olun):

Kod: Tümünü seç

zypper in ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libdvdcss2 vlc-codecs
Sonra sisteminizi güncelleyin. Muhtelen bu sizin sorununuzu düzeltecektir.
# zypper in ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libdvdcss2 vlc-codecs
Loading repository data...
Reading installed packages...
'gstreamer-plugins-bad' is already installed.
No update candidate for 'gstreamer-plugins-bad-1.14.4-5.1.x86_64'. The highest available version is already installed.
'ffmpeg' not found in package names. Trying capabilities.
'ffmpeg-4' providing 'ffmpeg' is already installed.
'gstreamer-plugins-ugly' is already installed.
There is an update candidate for 'gstreamer-plugins-ugly', but it is from a different vendor. Use 'zypper install gstreamer-plugins-ugly-1.14.4-4.4.x86_64' to install this candidate.
'gstreamer-plugins-libav' is already installed.
There is an update candidate for 'gstreamer-plugins-libav', but it is from a different vendor. Use 'zypper install gstreamer-plugins-libav-1.14.4-38.5.x86_64' to install this candidate.
'libdvdcss2' not found in package names. Trying capabilities.
No provider of 'libdvdcss2' found.

çalışmadı.
özür dilerim.
packman deposu altında yer alan libdvdcss2 deposunu kurmayı unutmuşum.
Onu yükleyince çalıştı.
Tamamdır, iyi günler dileriz o zaman :)